IDERA

Apache HTTP Mod Security

 GitHub: uptimesoftware/mod-apache-http-security
Tags : mod apache httpd
Category: mod

Version Compatibility
Module Name
Uptime Monitoring Station Version
Apache HTTP Mod Security7.8, 7.7, 7.6, 7.5, 7.4, 7.3, 7.2, 7.1, 7.0, 6.0
Download Files

Apache HTTP Mod Security

Information Table
Description: The Apache module "mod_security" allows us to apply a security layer on top of Apache without making any uptime core changes. It can protect Apache from various different security vulnerabilities and attacks, such as XSS (Cross Site Scripting) attacks. For more information on Mod Security, see [here](http://www.modsecurity.org)
Supported Monitoring Stations:7.8, 7.7, 7.6, 7.5, 7.4, 7.3, 7.2, 7.1, 7.0, 6.0
Supported Agents:None; no agent required
Installation Notes:
  1. Place the .so files in the */apache/modules* directory. On Linux the location is */usr/local/uptime/apache/modules*
  2. Place the modsecurity_rules.zip file in to the */apache/conf* directory and extract it. It should create a directory named *modsecurity_rules* with a bunch of .conf files in it. These are the rule files that mod_security will use. The modsecurity.conf file is used to configure mod_security as well. The defaults should be enough to work with Uptime.
  3. For Apache configuration and testing, see here.
Dependencies:

Apache

Input Variables:
    Output Variables:
      Languages Used:

        Notes:

        April 4, 2014 |

        Comments

        comments powered by Disqus
        Copyright © 2015 IDERA, Inc.   Legal   Privacy Statement